summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/radeonsi/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/drivers/radeonsi/Makefile.am')
-rw-r--r--src/gallium/drivers/radeonsi/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/gallium/drivers/radeonsi/Makefile.am b/src/gallium/drivers/radeonsi/Makefile.am
index c506666e3c8..0ed955db22c 100644
--- a/src/gallium/drivers/radeonsi/Makefile.am
+++ b/src/gallium/drivers/radeonsi/Makefile.am
@@ -25,6 +25,7 @@ include $(top_srcdir)/src/gallium/Automake.inc
AM_CFLAGS = \
$(GALLIUM_DRIVER_CFLAGS) \
+ -I$(top_srcdir)/src/amd/common \
$(RADEON_CFLAGS) \
$(LLVM_CFLAGS)
@@ -32,8 +33,8 @@ noinst_LTLIBRARIES = libradeonsi.la
libradeonsi_la_SOURCES = $(C_SOURCES) $(GENERATED_SOURCES)
-sid_tables.h: $(srcdir)/sid_tables.py $(srcdir)/sid.h
- $(AM_V_GEN) $(PYTHON2) $(srcdir)/sid_tables.py $(srcdir)/sid.h > $@
+sid_tables.h: $(srcdir)/sid_tables.py $(top_srcdir)/src/amd/common/sid.h
+ $(AM_V_GEN) $(PYTHON2) $(srcdir)/sid_tables.py $(top_srcdir)/src/amd/common/sid.h > $@
EXTRA_DIST = \
sid_tables.py