summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/radeon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/drivers/radeon/Makefile.am')
-rw-r--r--src/gallium/drivers/radeon/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/src/gallium/drivers/radeon/Makefile.am b/src/gallium/drivers/radeon/Makefile.am
new file mode 100644
index 00000000000..091adc4016d
--- /dev/null
+++ b/src/gallium/drivers/radeon/Makefile.am
@@ -0,0 +1,31 @@
+include Makefile.sources
+include $(top_srcdir)/src/gallium/Automake.inc
+
+if HAVE_GALLIUM_R600
+if HAVE_GALLIUM_RADEONSI
+lib_LTLIBRARIES = libllvmradeon@[email protected]
+libllvmradeon@VERSION@_la_LDFLAGS = -Wl,--no-undefined -shared -avoid-version \
+ $(LLVM_LDFLAGS)
+else
+noinst_LTLIBRARIES = libllvmradeon@[email protected]
+endif
+else
+noinst_LTLIBRARIES = libllvmradeon@[email protected]
+endif
+
+AM_CXXFLAGS = \
+ $(filter-out -DDEBUG, $(LLVM_CXXFLAGS)) \
+ $(DEFINES)
+
+AM_CFLAGS = \
+ $(GALLIUM_CFLAGS) \
+ $(LLVM_CFLAGS)
+
+libllvmradeon@VERSION@_la_SOURCES = \
+ $(CPP_FILES) \
+ $(C_FILES)
+
+libllvmradeon@VERSION@_la_LIBADD = \
+ $(top_builddir)/src/gallium/auxiliary/libgallium.la \
+ $(CLOCK_LIB) \
+ $(LLVM_LIBS)