summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/radeon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/drivers/radeon/Makefile.am')
-rw-r--r--src/gallium/drivers/radeon/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/gallium/drivers/radeon/Makefile.am b/src/gallium/drivers/radeon/Makefile.am
index 091adc4016d..e6eb2419d86 100644
--- a/src/gallium/drivers/radeon/Makefile.am
+++ b/src/gallium/drivers/radeon/Makefile.am
@@ -4,7 +4,7 @@ include $(top_srcdir)/src/gallium/Automake.inc
if HAVE_GALLIUM_R600
if HAVE_GALLIUM_RADEONSI
lib_LTLIBRARIES = libllvmradeon@[email protected]
-libllvmradeon@VERSION@_la_LDFLAGS = -Wl,--no-undefined -shared -avoid-version \
+libllvmradeon@VERSION@_la_LDFLAGS = -Wl, -shared -avoid-version \
$(LLVM_LDFLAGS)
else
noinst_LTLIBRARIES = libllvmradeon@[email protected]
@@ -26,6 +26,5 @@ libllvmradeon@VERSION@_la_SOURCES = \
$(C_FILES)
libllvmradeon@VERSION@_la_LIBADD = \
- $(top_builddir)/src/gallium/auxiliary/libgallium.la \
$(CLOCK_LIB) \
$(LLVM_LIBS)