summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/r600/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/drivers/r600/Makefile.am')
-rw-r--r--src/gallium/drivers/r600/Makefile.am28
1 files changed, 10 insertions, 18 deletions
diff --git a/src/gallium/drivers/r600/Makefile.am b/src/gallium/drivers/r600/Makefile.am
index cede6fa1ff1..b2e37085f23 100644
--- a/src/gallium/drivers/r600/Makefile.am
+++ b/src/gallium/drivers/r600/Makefile.am
@@ -3,23 +3,15 @@ AUTOMAKE_OPTIONS = subdir-objects
include Makefile.sources
include $(top_srcdir)/src/gallium/Automake.inc
-noinst_LTLIBRARIES = libr600.la
-
AM_CFLAGS = \
- -I$(top_srcdir)/src/gallium/drivers \
- -I$(top_srcdir)/include \
- $(GALLIUM_CFLAGS) \
- $(RADEON_CFLAGS) \
- $(VISIBILITY_CFLAGS)
+ $(GALLIUM_DRIVER_CFLAGS) \
+ $(RADEON_CFLAGS)
AM_CXXFLAGS = \
- -I$(top_srcdir)/src/gallium/drivers \
- -I$(top_srcdir)/include \
- -I$(top_srcdir)/src/gallium/include \
- -I$(top_srcdir)/src/gallium/auxiliary \
- $(RADEON_CFLAGS) \
- $(DEFINES) \
- $(VISIBILITY_CFLAGS)
+ $(GALLIUM_DRIVER_CXXFLAGS) \
+ $(RADEON_CFLAGS)
+
+noinst_LTLIBRARIES = libr600.la
libr600_la_SOURCES = \
$(C_SOURCES) \
@@ -29,15 +21,15 @@ libr600_la_LIBADD = ../radeon/libradeon.la
if NEED_RADEON_LLVM
+AM_CFLAGS += \
+ $(LLVM_CFLAGS) \
+ -I$(top_srcdir)/src/gallium/drivers/radeon/
+
libr600_la_SOURCES += \
$(LLVM_C_SOURCES)
libr600_la_LIBADD += ../radeon/libllvmradeon.la
-AM_CFLAGS += \
- $(LLVM_CFLAGS) \
- -I$(top_srcdir)/src/gallium/drivers/radeon/
-
endif
if USE_R600_LLVM_COMPILER