summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/r600/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/drivers/r600/Makefile.am')
-rw-r--r--src/gallium/drivers/r600/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/gallium/drivers/r600/Makefile.am b/src/gallium/drivers/r600/Makefile.am
index a067f2c4e72..43c8704618d 100644
--- a/src/gallium/drivers/r600/Makefile.am
+++ b/src/gallium/drivers/r600/Makefile.am
@@ -13,12 +13,14 @@ AM_CFLAGS = \
libr600_la_SOURCES = \
$(C_SOURCES)
+libr600_la_LIBADD = ../radeon/libradeon.la
+
if R600_NEED_RADEON_GALLIUM
libr600_la_SOURCES += \
$(LLVM_C_SOURCES)
-libr600_la_LIBADD = ../radeon/libllvmradeon@[email protected]
+libr600_la_LIBADD += ../radeon/libllvmradeon@[email protected]
AM_CFLAGS += \
$(LLVM_CFLAGS) \