summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/r300/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/drivers/r300/Makefile.am')
-rw-r--r--src/gallium/drivers/r300/Makefile.am14
1 files changed, 2 insertions, 12 deletions
diff --git a/src/gallium/drivers/r300/Makefile.am b/src/gallium/drivers/r300/Makefile.am
index 7692bd815ed..ead7a871977 100644
--- a/src/gallium/drivers/r300/Makefile.am
+++ b/src/gallium/drivers/r300/Makefile.am
@@ -13,11 +13,11 @@ AM_CFLAGS = \
$(LLVM_CFLAGS) \
$(RADEON_CFLAGS)
-noinst_LTLIBRARIES = libr300.la libr300-helper.la
+noinst_LTLIBRARIES = libr300.la
check_PROGRAMS = r300_compiler_tests
TESTS = r300_compiler_tests
-r300_compiler_tests_LDADD = libr300.la libr300-helper.la \
+r300_compiler_tests_LDADD = libr300.la \
$(top_builddir)/src/gallium/auxiliary/libgallium.la \
$(top_builddir)/src/util/libmesautil.la \
$(GALLIUM_COMMON_LIB_DEPS)
@@ -28,16 +28,6 @@ r300_compiler_tests_SOURCES = $(COMPILER_TESTS_SOURCES)
libr300_la_SOURCES = $(C_SOURCES)
-# These two files are included in libmesagallium, which is included in the dri
-# targets. So, they were added directly to r300g the dri-r300 target would have
-# duplicated symbols, and if they weren't the other *-r300 targets would fail
-# with undefined symbols.
-#
-# Solve this by building them into a separate helper library that can be linked
-# in place of libmesagallium.
-libr300_helper_la_CPPFLAGS = -I$(top_srcdir)/src
-libr300_helper_la_SOURCES = $(HELPER_SOURCES)
-
EXTRA_DIST = Android.mk \
compiler/tests/omod_two_writers.test \
compiler/tests/regalloc_tex_1d_swizzle.test