summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/r300/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/drivers/r300/Makefile.am')
-rw-r--r--src/gallium/drivers/r300/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/src/gallium/drivers/r300/Makefile.am b/src/gallium/drivers/r300/Makefile.am
index 9d660038010..8aa6707c175 100644
--- a/src/gallium/drivers/r300/Makefile.am
+++ b/src/gallium/drivers/r300/Makefile.am
@@ -3,21 +3,19 @@ AUTOMAKE_OPTIONS = subdir-objects
include Makefile.sources
include $(top_srcdir)/src/gallium/Automake.inc
-noinst_LTLIBRARIES = libr300.la libr300-helper.la
-check_PROGRAMS = r300_compiler_tests
-TESTS = r300_compiler_tests
-
AM_CFLAGS = \
- -I$(top_srcdir)/src/gallium/drivers \
-I$(top_srcdir)/src/mesa/program \
-I$(top_srcdir)/src/mesa \
-I$(top_srcdir)/src/glsl \
-I$(top_srcdir)/src/mapi \
- $(VISIBILITY_CFLAGS) \
- $(GALLIUM_CFLAGS) \
+ $(GALLIUM_DRIVER_CFLAGS) \
$(LLVM_CFLAGS) \
$(RADEON_CFLAGS)
+noinst_LTLIBRARIES = libr300.la libr300-helper.la
+check_PROGRAMS = r300_compiler_tests
+TESTS = r300_compiler_tests
+
r300_compiler_tests_LDADD = libr300.la libr300-helper.la \
$(top_builddir)/src/gallium/auxiliary/libgallium.la \
$(GALLIUM_DRI_LIB_DEPS)