summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/nouveau/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/drivers/nouveau/Makefile.am')
-rw-r--r--src/gallium/drivers/nouveau/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/src/gallium/drivers/nouveau/Makefile.am b/src/gallium/drivers/nouveau/Makefile.am
index 12e3da0334a..c4b51d9dff2 100644
--- a/src/gallium/drivers/nouveau/Makefile.am
+++ b/src/gallium/drivers/nouveau/Makefile.am
@@ -27,9 +27,15 @@ noinst_LTLIBRARIES = libnouveau.la
AM_CPPFLAGS = \
-I$(top_srcdir)/src/gallium/drivers/nouveau/include \
- -I$(top_srcdir)/src/gallium/drivers \
- -I$(top_srcdir)/include \
$(GALLIUM_CFLAGS) \
- $(LIBDRM_CFLAGS)
+ $(LIBDRM_CFLAGS) \
+ $(NOUVEAU_CFLAGS) \
+ $(VISIBILITY_CFLAGS)
-libnouveau_la_SOURCES = $(C_SOURCES)
+libnouveau_la_SOURCES = \
+ $(C_SOURCES) \
+ $(NV30_C_SOURCES) \
+ $(NV50_CODEGEN_SOURCES) \
+ $(NV50_C_SOURCES) \
+ $(NVC0_CODEGEN_SOURCES) \
+ $(NVC0_C_SOURCES)