summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/freedreno/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/drivers/freedreno/Makefile.am')
-rw-r--r--src/gallium/drivers/freedreno/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/gallium/drivers/freedreno/Makefile.am b/src/gallium/drivers/freedreno/Makefile.am
index 4b2629f77bd..cbf62c6daae 100644
--- a/src/gallium/drivers/freedreno/Makefile.am
+++ b/src/gallium/drivers/freedreno/Makefile.am
@@ -21,15 +21,16 @@ libfreedreno_la_SOURCES = \
noinst_PROGRAMS = ir3_compiler
+# XXX: Required due to the C++ sources in libnir/libglsl_util
+nodist_EXTRA_ir3_compiler_SOURCES = dummy.cpp
ir3_compiler_SOURCES = \
ir3/ir3_cmdline.c
ir3_compiler_LDADD = \
libfreedreno.la \
- ../../auxiliary/libgallium.la \
+ $(top_builddir)/src/gallium/auxiliary/libgallium.la \
$(top_builddir)/src/glsl/libnir.la \
$(top_builddir)/src/libglsl_util.la \
- -lstdc++ \
$(top_builddir)/src/util/libmesautil.la \
$(GALLIUM_COMMON_LIB_DEPS) \
$(FREEDRENO_LIBS)