summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/freedreno/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/drivers/freedreno/Makefile.am')
-rw-r--r--src/gallium/drivers/freedreno/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/gallium/drivers/freedreno/Makefile.am b/src/gallium/drivers/freedreno/Makefile.am
index 33563f5952b..ee5d506f2a3 100644
--- a/src/gallium/drivers/freedreno/Makefile.am
+++ b/src/gallium/drivers/freedreno/Makefile.am
@@ -17,4 +17,16 @@ libfreedreno_la_SOURCES = \
$(a3xx_SOURCES) \
$(ir3_SOURCES)
+noinst_PROGRAMS = ir3_compiler
+
+ir3_compiler_SOURCES = \
+ ir3/ir3_cmdline.c
+
+ir3_compiler_LDADD = \
+ libfreedreno.la \
+ ../../auxiliary/libgallium.la \
+ $(top_builddir)/src/util/libmesautil.la \
+ $(GALLIUM_COMMON_LIB_DEPS) \
+ $(FREEDRENO_LIBS)
+
EXTRA_DIST = Android.mk