summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/drivers/Makefile.am')
-rw-r--r--src/gallium/drivers/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/gallium/drivers/Makefile.am b/src/gallium/drivers/Makefile.am
index f2e7da110f9..0aa2653a0f1 100644
--- a/src/gallium/drivers/Makefile.am
+++ b/src/gallium/drivers/Makefile.am
@@ -38,6 +38,20 @@ endif
################################################################################
+if HAVE_NOOP_GALLIUM
+
+# Meta-driver which combines whichever software rasterizers have been
+# built into a single convenience library.
+
+noinst_LIBRARIES+= noop/libnoop.a
+
+noop_libnoop_a_SOURCES = \
+ noop/noop_pipe.c \
+ noop/noop_state.c
+
+endif
+
+################################################################################
SUBDIRS = $(GALLIUM_MAKE_DIRS)
# FIXME: Remove when the rest of Gallium is converted to automake.