summaryrefslogtreecommitdiffstats
path: root/src/gallium/drivers/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/drivers/Makefile.am')
-rw-r--r--src/gallium/drivers/Makefile.am84
1 files changed, 70 insertions, 14 deletions
diff --git a/src/gallium/drivers/Makefile.am b/src/gallium/drivers/Makefile.am
index c4dc6bf14df..25c680a033b 100644
--- a/src/gallium/drivers/Makefile.am
+++ b/src/gallium/drivers/Makefile.am
@@ -11,12 +11,10 @@ AM_CFLAGS = $(VISIBILITY_CFLAGS)
noinst_LTLIBRARIES =
-SUBDIRS = .
+SUBDIRS = . trace rbug
################################################################################
-if HAVE_GALAHAD_GALLIUM
-
noinst_LTLIBRARIES += galahad/libgalahad.la
galahad_libgalahad_la_SOURCES = \
@@ -24,12 +22,8 @@ galahad_libgalahad_la_SOURCES = \
galahad/glhd_context.c \
galahad/glhd_screen.c
-endif
-
################################################################################
-if HAVE_IDENTITY_GALLIUM
-
noinst_LTLIBRARIES += identity/libidentity.la
identity_libidentity_la_SOURCES = \
@@ -37,12 +31,8 @@ identity_libidentity_la_SOURCES = \
identity/id_context.c \
identity/id_screen.c
-endif
-
################################################################################
-if HAVE_NOOP_GALLIUM
-
# Meta-driver which combines whichever software rasterizers have been
# built into a single convenience library.
@@ -52,8 +42,6 @@ noop_libnoop_la_SOURCES = \
noop/noop_pipe.c \
noop/noop_state.c
-endif
-
################################################################################
if HAVE_GALLIUM_R600
@@ -72,4 +60,72 @@ endif
################################################################################
-SUBDIRS += $(GALLIUM_MAKE_DIRS)
+if HAVE_GALLIUM_FREEDRENO
+
+SUBDIRS += freedreno
+
+endif
+
+################################################################################
+
+if HAVE_GALLIUM_I915
+
+SUBDIRS += i915
+
+endif
+
+################################################################################
+
+if HAVE_GALLIUM_NOUVEAU
+
+SUBDIRS += nouveau nv30 nv50 nvc0
+
+endif
+
+################################################################################
+
+if HAVE_GALLIUM_SVGA
+
+SUBDIRS += svga
+
+endif
+
+################################################################################
+
+if HAVE_GALLIUM_R300
+
+SUBDIRS += r300
+
+endif
+
+################################################################################
+
+if HAVE_GALLIUM_R600
+
+SUBDIRS += r600
+
+endif
+
+################################################################################
+
+if HAVE_GALLIUM_RADEONSI
+
+SUBDIRS += radeonsi
+
+endif
+
+################################################################################
+
+if NEED_GALLIUM_SOFTPIPE_DRIVER
+
+SUBDIRS += softpipe
+
+endif
+
+################################################################################
+
+if NEED_GALLIUM_LLVMPIPE_DRIVER
+
+SUBDIRS += llvmpipe
+
+endif