aboutsummaryrefslogtreecommitdiffstats
path: root/src/egl/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build27
1 files changed, 17 insertions, 10 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index 14aca2a2186..7038a68e955 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -173,18 +173,25 @@ libegl = shared_library(
version : egl_lib_version,
)
-if not with_glvnd
- pkg.generate(
- name : 'egl',
- description : 'Mesa EGL Library',
- version : meson.project_version(),
- libraries : libegl,
- libraries_private: gl_priv_libs,
- requires_private : gl_priv_reqs,
- extra_cflags : gl_pkgconfig_c_flags,
- )
+# If using glvnd the pkg-config header should not point to EGL_mesa, it should
+# point to EGL. glvnd is only available on unix like platforms so adding -l
+# should be safe here
+if with_glvnd and glvnd_missing_pc_files
+ _egl = '-L${libdir} -lEGL'
+else
+ _egl = libegl
endif
+pkg.generate(
+ name : 'egl',
+ description : 'Mesa EGL Library',
+ version : meson.project_version(),
+ libraries : _egl,
+ libraries_private: gl_priv_libs,
+ requires_private : gl_priv_reqs,
+ extra_cflags : gl_pkgconfig_c_flags,
+)
+
if with_tests and prog_nm.found()
if with_glvnd
egl_symbols = files('egl-glvnd-symbols.txt')