summaryrefslogtreecommitdiffstats
path: root/src/egl/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/egl/meson.build')
-rw-r--r--src/egl/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/egl/meson.build b/src/egl/meson.build
index ea7ae06761f..cc51671f9d8 100644
--- a/src/egl/meson.build
+++ b/src/egl/meson.build
@@ -129,7 +129,10 @@ if with_platform_wayland
'wayland/wayland-egl', 'wayland/wayland-drm',
)
endif
-# TODO: android
+if with_platform_android
+ deps_for_egl += dep_android
+ files_egl += files('drivers/dri2/platform_android.c')
+endif
# TODO: glvnd