summaryrefslogtreecommitdiffstats
path: root/src/egl/drivers/dri2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/egl/drivers/dri2/Makefile.am')
-rw-r--r--src/egl/drivers/dri2/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/egl/drivers/dri2/Makefile.am b/src/egl/drivers/dri2/Makefile.am
index f589600be0f..55be4a75ba5 100644
--- a/src/egl/drivers/dri2/Makefile.am
+++ b/src/egl/drivers/dri2/Makefile.am
@@ -65,4 +65,9 @@ libegl_dri2_la_SOURCES += platform_drm.c
AM_CFLAGS += -DHAVE_DRM_PLATFORM
endif
+if HAVE_EGL_PLATFORM_SURFACELESS
+libegl_dri2_la_SOURCES += platform_surfaceless.c
+AM_CFLAGS += -DHAVE_SURFACELESS_PLATFORM
+endif
+
EXTRA_DIST = SConscript