summaryrefslogtreecommitdiffstats
path: root/src/compiler/nir/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/compiler/nir/meson.build')
-rw-r--r--src/compiler/nir/meson.build14
1 files changed, 7 insertions, 7 deletions
diff --git a/src/compiler/nir/meson.build b/src/compiler/nir/meson.build
index 010da386ce3..8708f9b069c 100644
--- a/src/compiler/nir/meson.build
+++ b/src/compiler/nir/meson.build
@@ -24,7 +24,7 @@ nir_builder_opcodes_h = custom_target(
'nir_builder_opcodes.h',
input : 'nir_builder_opcodes_h.py',
output : 'nir_builder_opcodes.h',
- command : [prog_python2, '@INPUT@'],
+ command : [prog_python, '@INPUT@'],
capture : true,
depend_files : nir_depends,
)
@@ -33,7 +33,7 @@ nir_constant_expressions_c = custom_target(
'nir_constant_expressions.c',
input : 'nir_constant_expressions.py',
output : 'nir_constant_expressions.c',
- command : [prog_python2, '@INPUT@'],
+ command : [prog_python, '@INPUT@'],
capture : true,
depend_files : nir_depends,
)
@@ -42,7 +42,7 @@ nir_opcodes_h = custom_target(
'nir_opcodes.h',
input : 'nir_opcodes_h.py',
output : 'nir_opcodes.h',
- command : [prog_python2, '@INPUT@'],
+ command : [prog_python, '@INPUT@'],
capture : true,
depend_files : nir_depends,
)
@@ -51,7 +51,7 @@ nir_opcodes_c = custom_target(
'nir_opcodes.c',
input : 'nir_opcodes_c.py',
output : 'nir_opcodes.c',
- command : [prog_python2, '@INPUT@'],
+ command : [prog_python, '@INPUT@'],
capture : true,
depend_files : nir_depends,
)
@@ -60,7 +60,7 @@ nir_opt_algebraic_c = custom_target(
'nir_opt_algebraic.c',
input : 'nir_opt_algebraic.py',
output : 'nir_opt_algebraic.c',
- command : [prog_python2, '@INPUT@'],
+ command : [prog_python, '@INPUT@'],
capture : true,
depend_files : files('nir_algebraic.py'),
)
@@ -69,7 +69,7 @@ nir_intrinsics_h = custom_target(
'nir_intrinsics.h',
input : 'nir_intrinsics_h.py',
output : 'nir_intrinsics.h',
- command : [prog_python2, '@INPUT@', '--outdir', meson.current_build_dir()],
+ command : [prog_python, '@INPUT@', '--outdir', meson.current_build_dir()],
capture : false,
depend_files : files('nir_intrinsics.py'),
)
@@ -78,7 +78,7 @@ nir_intrinsics_c = custom_target(
'nir_intrinsic.c',
input : 'nir_intrinsics_c.py',
output : 'nir_intrinsics.c',
- command : [prog_python2, '@INPUT@', '--outdir', meson.current_build_dir()],
+ command : [prog_python, '@INPUT@', '--outdir', meson.current_build_dir()],
capture: false,
depend_files : files('nir_intrinsics.py'),
)