summaryrefslogtreecommitdiffstats
path: root/src/compiler/glsl/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/compiler/glsl/meson.build')
-rw-r--r--src/compiler/glsl/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/compiler/glsl/meson.build b/src/compiler/glsl/meson.build
index b0c0de810a6..26ab4f1c8d3 100644
--- a/src/compiler/glsl/meson.build
+++ b/src/compiler/glsl/meson.build
@@ -230,7 +230,8 @@ glsl_compiler = executable(
dependencies : [dep_clock, dep_thread],
include_directories : [inc_common],
link_with : [libglsl_standalone],
- build_by_default : false,
+ build_by_default : with_tools.contains('glsl'),
+ install : with_tools.contains('glsl'),
)
glsl_test = executable(
@@ -242,7 +243,8 @@ glsl_test = executable(
include_directories : [inc_common],
dependencies : [dep_clock, dep_thread],
link_with : [libglsl, libglsl_standalone, libglsl_util],
- build_by_default : false,
+ build_by_default : with_tools.contains('glsl'),
+ install : with_tools.contains('glsl'),
)
if with_tests