summaryrefslogtreecommitdiffstats
path: root/src/compiler/glsl/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/compiler/glsl/meson.build')
-rw-r--r--src/compiler/glsl/meson.build10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/compiler/glsl/meson.build b/src/compiler/glsl/meson.build
index 71b4c42e4d7..8096f2d048e 100644
--- a/src/compiler/glsl/meson.build
+++ b/src/compiler/glsl/meson.build
@@ -53,6 +53,13 @@ ir_expression_operation_strings_h = custom_target(
capture : true,
)
+float64_glsl_h = custom_target(
+ 'float64_glsl.h',
+ input : ['xxd.py', 'float64.glsl'],
+ output : 'float64_glsl.h',
+ command : [prog_python, '@INPUT@', '@OUTPUT@', '-n', 'float64_source'],
+)
+
files_libglsl = files(
'ast.h',
'ast_array_index.cpp',
@@ -213,7 +220,8 @@ files_libglsl_standalone = files(
libglsl = static_library(
'glsl',
[files_libglsl, glsl_parser, glsl_lexer_cpp, ir_expression_operation_h,
- ir_expression_operation_strings_h, ir_expression_operation_constant_h],
+ ir_expression_operation_strings_h, ir_expression_operation_constant_h,
+ float64_glsl_h],
c_args : [c_vis_args, c_msvc_compat_args, no_override_init_args],
cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
link_with : libglcpp,