summaryrefslogtreecommitdiffstats
path: root/src/compiler/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/compiler/Makefile.am')
-rw-r--r--src/compiler/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/compiler/Makefile.am b/src/compiler/Makefile.am
index 0bc8e48efa6..e3d297fe299 100644
--- a/src/compiler/Makefile.am
+++ b/src/compiler/Makefile.am
@@ -84,7 +84,7 @@ check_PROGRAMS += \
glsl/tests/sampler-types-test \
glsl/tests/uniform-initializer-test
-noinst_PROGRAMS = glsl_compiler
+noinst_PROGRAMS = glsl_compiler spirv2nir
glsl_tests_blob_test_SOURCES = \
glsl/tests/blob_test.c
@@ -176,6 +176,15 @@ glsl_glsl_test_LDADD = \
$(top_builddir)/src/libglsl_util.la \
$(PTHREAD_LIBS)
+spirv2nir_SOURCES = \
+ nir/spirv2nir.c
+
+spirv2nir_LDADD = \
+ nir/libnir.la \
+ $(top_builddir)/src/util/libmesautil.la \
+ -lm -lstdc++ \
+ $(PTHREAD_LIBS)
+
# We write our own rules for yacc and lex below. We'd rather use automake,
# but automake makes it especially difficult for a number of reasons:
#
@@ -262,6 +271,7 @@ nir_libnir_la_LIBADD = \
nir_libnir_la_SOURCES = \
$(NIR_FILES) \
+ $(SPIRV_FILES) \
$(NIR_GENERATED_FILES)
PYTHON_GEN = $(AM_V_GEN)$(PYTHON2) $(PYTHON_FLAGS)