summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 29d4ea94ca9..6ce57916031 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -38,14 +38,21 @@ if HAVE_DRI_GLX
SUBDIRS += glx
endif
+## Optionally required by GBM and EGL
if HAVE_PLATFORM_WAYLAND
-SUBDIRS += egl/wayland/wayland-egl egl/wayland/wayland-drm
+SUBDIRS += egl/wayland/wayland-drm
endif
+## Optionally required by EGL (aka PLATFORM_GBM)
if HAVE_GBM
SUBDIRS += gbm
endif
+## Optionally required by EGL
+if HAVE_PLATFORM_WAYLAND
+SUBDIRS += egl/wayland/wayland-egl
+endif
+
if HAVE_EGL
SUBDIRS += egl
endif