summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a0572b7a563..1471fa0e48a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -24,10 +24,19 @@ SUBDIRS = . gtest util mapi/glapi/gen mapi
# include only conditionally ?
SUBDIRS += compiler
+if HAVE_INTEL_DRIVERS
+SUBDIRS += intel
+endif
+
if NEED_OPENGL_COMMON
SUBDIRS += mesa
endif
+# This explicitly comes after mesa because it depends on the i965 compiler
+if HAVE_INTEL_VULKAN
+SUBDIRS += intel/vulkan
+endif
+
SUBDIRS += loader
if HAVE_DRI_GLX
@@ -56,10 +65,6 @@ EXTRA_DIST = \
AM_CFLAGS = $(VISIBILITY_CFLAGS)
AM_CXXFLAGS = $(VISIBILITY_CXXFLAGS)
-if HAVE_INTEL_DRIVERS
-SUBDIRS += intel
-endif
-
AM_CPPFLAGS = \
-I$(top_srcdir)/include/ \
-I$(top_srcdir)/src/mapi/ \