summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 91d6a7adb31..17c8798323a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -74,7 +74,7 @@ endif
# include only conditionally ?
SUBDIRS += compiler
-if HAVE_GALLIUM_RADEON_COMMON
+if HAVE_AMD_DRIVERS
SUBDIRS += amd
endif
@@ -120,6 +120,12 @@ if HAVE_INTEL_VULKAN
SUBDIRS += intel/vulkan
endif
+# Requires wayland-drm
+if HAVE_RADEON_VULKAN
+SUBDIRS += amd/common
+SUBDIRS += amd/vulkan
+endif
+
if HAVE_GALLIUM
SUBDIRS += gallium
endif