aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 9 insertions, 10 deletions
diff --git a/meson.build b/meson.build
index bb6a835084f..9bb114056b1 100644
--- a/meson.build
+++ b/meson.build
@@ -464,29 +464,28 @@ endif
_omx = get_option('gallium-omx')
if not system_has_kms_drm
- if _omx == 'true'
+ if _omx != 'disabled'
error('OMX state tracker can only be built on unix-like OSes.')
else
- _omx = 'false'
+ _omx = 'disabled'
endif
elif not (with_platform_x11 or with_platform_drm)
- if _omx == 'true'
+ if _omx != 'disabled'
error('OMX state tracker requires X11 or drm platform support.')
else
- _omx = 'false'
+ _omx = 'disabled'
endif
elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
- if _omx == 'true'
+ if _omx != 'disabled'
error('OMX state tracker requires at least one of the following gallium drivers: r600, radeonsi, nouveau.')
else
- _omx = 'false'
+ _omx = 'disabled'
endif
-elif _omx == 'auto'
- _omx = 'true'
endif
-with_gallium_omx = _omx == 'true'
+with_gallium_omx = _omx != 'disabled'
+gallium_omx = _omx
dep_omx = []
-if with_gallium_omx
+if gallium_omx == 'bellagio'
dep_omx = dependency('libomxil-bellagio')
endif