summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 030ab0c6260..b61c285bf00 100644
--- a/meson.build
+++ b/meson.build
@@ -909,6 +909,10 @@ if cc.links('int main() { return 0; }',
name : 'dynamic-list')
with_ld_dynamic_list = true
endif
+ld_args_build_id = []
+if build_machine.system() != 'darwin'
+ ld_args_build_id += '-Wl,--build-id=sha1'
+endif
# check for dl support
if cc.has_function('dlopen')