summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 5ca5c64954a..b6293760faf 100644
--- a/meson.build
+++ b/meson.build
@@ -88,6 +88,7 @@ with_dri = false
with_dri_i915 = false
with_dri_i965 = false
with_dri_r100 = false
+with_dri_r200 = false
with_dri_swrast = false
_drivers = get_option('dri-drivers')
if _drivers != ''
@@ -95,6 +96,7 @@ if _drivers != ''
with_dri_i915 = _split.contains('i915')
with_dri_i965 = _split.contains('i965')
with_dri_r100 = _split.contains('r100')
+ with_dri_r200 = _split.contains('r200')
with_dri_swrast = _split.contains('swrast')
with_dri = true
endif
@@ -629,7 +631,7 @@ dep_libdrm_freedreno = []
if with_amd_vk or with_gallium_radeonsi
dep_libdrm_amdgpu = dependency('libdrm_amdgpu', version : '>= 2.4.85')
endif
-if with_gallium_radeonsi or with_dri_r100 # older radeon too
+if with_gallium_radeonsi or with_dri_r100 or with_dri_r200
dep_libdrm_radeon = dependency('libdrm_radeon', version : '>= 2.4.71')
endif
if with_gallium_nouveau