summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 7436164946b..c9ef70346a1 100644
--- a/meson.build
+++ b/meson.build
@@ -698,9 +698,15 @@ if with_platform_haiku
endif
prog_python = find_program('python3')
-has_mako = run_command(prog_python, '-c', 'import mako')
+has_mako = run_command(
+ prog_python, '-c',
+ '''
+from distutils.version import StrictVersion
+import mako
+assert StrictVersion(mako.__version__) > StrictVersion("0.8.0")
+ ''')
if has_mako.returncode() != 0
- error('Python (3.x) mako module required to build mesa.')
+ error('Python (3.x) mako module >= 0.8.0 required to build mesa.')
endif
if cc.get_id() == 'gcc' and cc.version().version_compare('< 4.4.6')