summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 0 insertions, 12 deletions
diff --git a/meson.build b/meson.build
index f0fa57ca515..a2978117409 100644
--- a/meson.build
+++ b/meson.build
@@ -503,12 +503,6 @@ if not system_has_kms_drm
else
error('OMX state tracker can only be built on unix-like OSes.')
endif
-elif not (with_platform_x11 or with_platform_drm)
- if ['auto', 'disabled'].contains(_omx)
- _omx = 'disabled'
- else
- error('OMX state tracker requires X11 or drm platform support.')
- endif
elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
if ['auto', 'disabled'].contains(_omx)
_omx = 'disabled'
@@ -589,12 +583,6 @@ if not system_has_kms_drm
else
_va = 'false'
endif
-elif not (with_platform_x11 or with_platform_drm)
- if _va == 'true'
- error('VA state tracker requires X11 or drm or wayland platform support.')
- else
- _va = 'false'
- endif
elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
if _va == 'true'
error('VA state tracker requires at least one of the following gallium drivers: r600, radeonsi, nouveau.')