summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 7a536982da6..7b337755544 100644
--- a/meson.build
+++ b/meson.build
@@ -375,6 +375,9 @@ if with_glvnd
elif with_glx == 'disabled' and not with_egl
error('glvnd requires DRI based GLX and/or EGL')
endif
+ if get_option('egl-lib-suffix') != ''
+ error('''EGL lib suffix can't be used with libglvnd''')
+ endif
endif
if with_vulkan_icd_dir == ''