summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 9184b69ea8a..3623d3dc0fd 100644
--- a/meson.build
+++ b/meson.build
@@ -1030,11 +1030,16 @@ if host_machine.system() == 'windows'
if cc.get_id() == 'msvc'
add_project_link_arguments(
'/fixed:no',
- '/incremental:no',
'/dynamicbase',
'/nxcompat',
language : ['c', 'cpp'],
)
+ if get_option('buildtype') != 'debug'
+ add_project_link_arguments(
+ '/incremental:no',
+ language : ['c', 'cpp'],
+ )
+ endif
else
add_project_link_arguments(
'-Wl,--nxcompat',