summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ff5666c207e..e96dc864986 100644
--- a/meson.build
+++ b/meson.build
@@ -99,6 +99,7 @@ if _drivers != ''
_split = _drivers.split(',')
with_gallium_radeonsi = _split.contains('radeonsi')
with_gallium_nouveau = _split.contains('nouveau')
+ with_gallium_softpipe = _split.contains('swrast')
with_gallium = true
with_dri = true
endif
@@ -111,6 +112,10 @@ if not (with_dri or with_gallium)
with_shared_glapi = false
endif
+if with_dri_swrast and with_gallium_softpipe
+ error('Only one swrast provider can be built')
+endif
+
dep_libdrm_intel = []
if with_dri_i915
dep_libdrm_intel = dependency('libdrm_intel', version : '>= 2.4.75')