summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2115871931d..65c6b98609e 100644
--- a/meson.build
+++ b/meson.build
@@ -926,6 +926,17 @@ if get_option('gallium-extra-hud')
pre_args += '-DHAVE_GALLIUM_EXTRA_HUD=1'
endif
+_sensors = get_option('lmsensors')
+if _sensors != 'false'
+ dep_lmsensors = cc.find_library('libsensors', required : _sensors == 'true')
+ if dep_lmsensors.found()
+ pre_args += '-DHAVE_LIBSENSORS=1'
+ endif
+else
+ dep_lmsensors = []
+endif
+
+
# TODO: nine
# TODO: clover