summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 4ba00283cec..02264aeed4e 100644
--- a/meson.build
+++ b/meson.build
@@ -72,16 +72,23 @@ if (with_gles1 or with_gles2) and not with_opengl
endif
with_dri = false
+with_dri_i915 = false
with_dri_i965 = false
with_dri_swrast = false
_drivers = get_option('dri-drivers')
if _drivers != ''
_split = _drivers.split(',')
+ with_dri_i915 = _split.contains('i915')
with_dri_i965 = _split.contains('i965')
with_dri_swrast = _split.contains('swrast')
with_dri = true
endif
+dep_libdrm_intel = []
+if with_dri_i915
+ dep_libdrm_intel = dependency('libdrm_intel', version : '>= 2.4.75')
+endif
+
if not with_dri
with_gles1 = false
with_gles2 = false