summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 46f86eb0000..8a40c48e435 100644
--- a/meson.build
+++ b/meson.build
@@ -376,7 +376,8 @@ if with_vulkan_icd_dir == ''
with_vulkan_icd_dir = join_paths(get_option('datadir'), 'vulkan/icd.d')
endif
-with_dri2 = (with_dri or with_any_vk) and with_dri_platform == 'drm'
+with_dri2 = (with_dri or with_any_vk) and (with_dri_platform == 'drm' or
+ host_machine.system() == 'gnu')
_dri3 = get_option('dri3')
if _dri3 == 'auto'
with_dri3 = system_has_kms_drm and with_dri2