summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 00cf3e017ab..b4cd7999566 100644
--- a/meson.build
+++ b/meson.build
@@ -199,12 +199,8 @@ with_gallium_virgl = gallium_drivers.contains('virgl')
with_gallium_swr = gallium_drivers.contains('swr')
with_gallium_lima = gallium_drivers.contains('lima')
-if cc.get_id() == 'intel'
- if meson.version().version_compare('< 0.49.0')
- error('Meson does not have sufficient support of ICC before 0.49.0 to compile mesa')
- elif with_gallium_swr and meson.version().version_compare('== 0.49.0')
- warning('Meson as of 0.49.0 is sufficient for compiling mesa with ICC, but there are some caveats with SWR. 0.49.1 should resolve all of these')
- endif
+if cc.get_id().startswith('intel') and meson.version().version_compare('< 0.49.1')
+ error('Meson does not have sufficient support of ICC before 0.49.1 to compile mesa')
endif
with_gallium = gallium_drivers.length() != 0 and gallium_drivers != ['']