summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ef06ea8f6b7..8988deae783 100644
--- a/meson.build
+++ b/meson.build
@@ -715,6 +715,9 @@ if with_osmesa != 'none'
if with_osmesa == 'classic' and not with_dri_swrast
error('OSMesa classic requires dri (classic) swrast.')
endif
+ if with_osmesa == 'gallium' and not with_gallium_softpipe
+ error('OSMesa gallium requires gallium softpipe or llvmpipe.')
+ endif
osmesa_lib_name = 'OSMesa'
osmesa_bits = get_option('osmesa-bits')
if osmesa_bits != '8'