summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 1da1bb06798..49a0ef6d405 100644
--- a/meson.build
+++ b/meson.build
@@ -694,8 +694,11 @@ endif
prog_bison = find_program('bison', required : with_any_opengl)
prog_flex = find_program('flex', required : with_any_opengl)
-# TODO: selinux
dep_selinux = []
+if get_option('selinux')
+ dep_selinux = dependency('libselinux')
+ pre_args += '-DMESA_SELINUX'
+endif
# TODO: llvm-prefix and llvm-shared-libs