summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index d4f460e0b6e..4aafba802a5 100644
--- a/meson.build
+++ b/meson.build
@@ -357,8 +357,12 @@ if with_glx != 'disabled'
if with_dri
error('xlib conflicts with any dri driver')
endif
- elif with_glx == 'dri' and not with_dri
- error('dri based GLX requires at least one DRI driver')
+ elif with_glx == 'dri'
+ if not with_dri
+ error('dri based GLX requires at least one DRI driver')
+ elif not with_shared_glapi
+ error('dri based GLX requires shared-glapi')
+ endif
endif
endif