summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index e759bbf96a5..c5bc94720d6 100644
--- a/meson.build
+++ b/meson.build
@@ -382,8 +382,8 @@ if with_any_vk and (with_platform_x11 and not with_dri3)
error('Vulkan drivers require dri3 for X11 support')
endif
if with_dri
- if with_glx == 'disabled' and not with_egl and not with_gbm
- error('building dri drivers require at least one windowing system')
+ if with_glx == 'disabled' and not with_egl and not with_gbm and with_osmesa != 'classic'
+ error('building dri drivers require at least one windowing system or classic osmesa')
endif
endif