aboutsummaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2da66b74924..4e1990eb600 100644
--- a/meson.build
+++ b/meson.build
@@ -746,7 +746,11 @@ if with_platform_haiku
pre_args += '-DHAVE_HAIKU_PLATFORM'
endif
-prog_python = import('python3').find_python()
+if meson.version().version_compare('>=0.50')
+ prog_python = import('python').find_installation('python3')
+else
+ prog_python = import('python3').find_python()
+endif
has_mako = run_command(
prog_python, '-c',
'''