summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 4 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 20c40f1d221..28a2e6803c6 100644
--- a/meson.build
+++ b/meson.build
@@ -1328,13 +1328,12 @@ else
endif
dep_glvnd = null_dep
-glvnd_missing_pc_files = false
+glvnd_has_headers_and_pc_files = false
if with_glvnd
dep_glvnd = dependency('libglvnd', version : '>= 0.2.0')
- # GLVND until commit 0dfaea2bcb7cdcc785f9 ("Add pkg-config files for EGL, GL,
- # GLES, and GLX.") was missing its pkg-config files, forcing every vendor to
- # provide them and the distro maintainers to resolve the conflict.
- glvnd_missing_pc_files = dep_glvnd.version().version_compare('< 1.2.0')
+ # GLVND before 1.2 was missing its pkg-config and header files, forcing every
+ # vendor to provide them and the distro maintainers to resolve the conflict.
+ glvnd_has_headers_and_pc_files = dep_glvnd.version().version_compare('>= 1.2.0')
pre_args += '-DUSE_LIBGLVND=1'
endif