summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/libgl1-mesa-glx.shlibs1
-rw-r--r--debian/libgl1-mesa-swx11-dev.install2
-rw-r--r--debian/libgl1-mesa-swx11.shlibs2
-rw-r--r--debian/libglu1-mesa.shlibs1
-rwxr-xr-xdebian/rules6
5 files changed, 10 insertions, 2 deletions
diff --git a/debian/libgl1-mesa-glx.shlibs b/debian/libgl1-mesa-glx.shlibs
new file mode 100644
index 00000000000..b8e0fbaaaa5
--- /dev/null
+++ b/debian/libgl1-mesa-glx.shlibs
@@ -0,0 +1 @@
+libGL 1 libgl1-mesa-glx | libgl1
diff --git a/debian/libgl1-mesa-swx11-dev.install b/debian/libgl1-mesa-swx11-dev.install
index 2258776adea..9944522595f 100644
--- a/debian/libgl1-mesa-swx11-dev.install
+++ b/debian/libgl1-mesa-swx11-dev.install
@@ -1,3 +1,5 @@
usr/include/GL/glx*.h
usr/lib/libGL.a
usr/lib/libGL.so
+usr/lib/libOSMesa.a
+usr/lib/libOSMesa.so
diff --git a/debian/libgl1-mesa-swx11.shlibs b/debian/libgl1-mesa-swx11.shlibs
new file mode 100644
index 00000000000..f4b6356179c
--- /dev/null
+++ b/debian/libgl1-mesa-swx11.shlibs
@@ -0,0 +1,2 @@
+libGL 1 libgl1-mesa-glx | libgl1
+libOSMesa 6 libgl1-mesa-swx11 | libgl1-mesa-glide3
diff --git a/debian/libglu1-mesa.shlibs b/debian/libglu1-mesa.shlibs
new file mode 100644
index 00000000000..647fc5be38a
--- /dev/null
+++ b/debian/libglu1-mesa.shlibs
@@ -0,0 +1 @@
+libGLU 1 libglu1-mesa | libglu1
diff --git a/debian/rules b/debian/rules
index ef8b0fa31f0..fbf328332e8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -56,6 +56,9 @@ endif
# available for the build architecture. Use with caution =)
#SWX11_GLU_CONFIGS += $(subst configs/,,$(wildcard configs/debian-swx11+glu-$(DEB_BUILD_ARCH)-*))
+# build a static version of swx11 and GLU as well
+SWX11_GLU_CONFIGS += debian-swx11+glu-static
+
# choose an architecture-specific configuration for building the DRI-enabled
# libGL if one exists
ifneq ($(wildcard configs/debian-dri-$(DEB_BUILD_ARCH)),)
@@ -70,8 +73,7 @@ CONFIGS = $(SWX11_GLU_CONFIGS) \
debian-osmesa16 \
debian-osmesa16-static \
debian-osmesa32 \
- debian-osmesa32-static \
- debian-static
+ debian-osmesa32-static
STAMP = $(STAMP_DIR)/$(DEB_BUILD_GNU_TYPE)
BUILD_STAMPS = $(addprefix $(STAMP)-build-, $(CONFIGS))