summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 4 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 7042fe1c0a2..0d6386f82e3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -187,16 +187,15 @@ $(STAMP)-build-%: configure
touch $@
-install:
+install: build
# Add here commands to install the package into debian/tmp
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
- $(MAKE) -f debian/rules $(INSTALL_TARGETS)
-
-install-%: $(STAMP)-build-%
- cd $(DEB_BUILD_DIR)/$* && $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+ set -e; for config in $(CONFIGS); do \
+ $(MAKE) -C $(DEB_BUILD_DIR)/$$config DESTDIR=$(CURDIR)/debian/tmp install; \
+ done
clean: unpatch
dh_testdir