aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6771aa64e16..33f1c42c8be 100644
--- a/configure.ac
+++ b/configure.ac
@@ -468,12 +468,10 @@ dnl explicitly requested. If both disabled, set to static since shared
dnl was explicitly requested.
case "x$enable_static$enable_shared" in
xyesyes)
- AC_MSG_WARN([Cannot build static and shared libraries, disabling shared])
- enable_shared=no
+ AC_MSG_ERROR([Cannot enable both static and shared. Building using --enable-shared is strongly recommended])
;;
xnono)
- AC_MSG_WARN([Cannot disable both static and shared libraries, enabling shared])
- enable_shared=yes
+ AC_MSG_ERROR([Cannot disable both static and shared. Building using --enable-shared is strongly recommended])
;;
esac