summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2c24a59a57a..75182ee730e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1239,6 +1239,14 @@ dnl
dnl XA configuration
dnl
if test "x$enable_xa" = xyes; then
+ if test "x$with_gallium_drivers" = xswrast; then
+ AC_MSG_ERROR([
+ Building xa requires at least one non swrast gallium driver.
+ If you are looking to use libxatracker.so with vmware's virtual gpu,
+ make sure to include svga in the gallium drivers list, apart from
+ enabling XA.
+ Example: ./configure --enable-xa --with-gallium-drivers=svga...])
+ fi
GALLIUM_STATE_TRACKERS_DIRS="xa $GALLIUM_STATE_TRACKERS_DIRS"
enable_gallium_loader=yes
enable_gallium_drm_loader=yes