summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 2c930004cfb..de422107a26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1643,14 +1643,10 @@ AC_ARG_WITH([egl-platforms],
[with_egl_platforms=auto])
if test "x$with_egl_platforms" = xauto; then
- if test "x$enable_egl" = xyes; then
- if test "x$enable_gbm" = xyes; then
- with_egl_platforms="x11,drm"
- else
- with_egl_platforms="x11"
- fi
+ if test "x$enable_gbm" = xyes; then
+ with_egl_platforms="x11,drm"
else
- with_egl_platforms=""
+ with_egl_platforms="x11"
fi
else
AC_MSG_WARN([--with-egl-platforms is deprecated. Use --with-platforms instead.])