summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 6141a5493e6..5e1d09166ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -320,19 +320,22 @@ dnl
dnl library names
dnl
if test "$enable_static" = yes; then
- LIB_EXTENSION='a'
+ LIB_EXT='a'
else
case "$host_os" in
darwin* )
- LIB_EXTENSION='dylib' ;;
+ LIB_EXT='dylib' ;;
cygwin* )
- LIB_EXTENSION='dll' ;;
+ LIB_EXT='dll' ;;
aix* )
- LIB_EXTENSION='a' ;;
+ LIB_EXT='a' ;;
* )
- LIB_EXTENSION='so' ;;
+ LIB_EXT='so' ;;
esac
fi
+
+AC_SUBST([LIB_EXT])
+
AC_ARG_WITH([gl-lib-name],
[AS_HELP_STRING([--with-gl-lib-name@<:@=NAME@:>@],
[specify GL library name @<:@default=GL@:>@])],