summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c9dc51bc0d8..7fade23b6af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -766,6 +766,13 @@ if test "x$enable_asm" = xyes; then
;;
esac
;;
+ powerpc64le)
+ case "$host_os" in
+ linux*)
+ asm_arch=ppc64le
+ ;;
+ esac
+ ;;
esac
case "$asm_arch" in
@@ -781,6 +788,10 @@ if test "x$enable_asm" = xyes; then
DEFINES="$DEFINES -DUSE_SPARC_ASM"
AC_MSG_RESULT([yes, sparc])
;;
+ ppc64le)
+ DEFINES="$DEFINES -DUSE_PPC64LE_ASM"
+ AC_MSG_RESULT([yes, ppc64le])
+ ;;
*)
AC_MSG_RESULT([no, platform not supported])
;;
@@ -2663,6 +2674,7 @@ AM_CONDITIONAL(HAVE_COMMON_OSMESA, test "x$enable_osmesa" = xyes -o \
AM_CONDITIONAL(HAVE_X86_ASM, test "x$asm_arch" = xx86 -o "x$asm_arch" = xx86_64)
AM_CONDITIONAL(HAVE_X86_64_ASM, test "x$asm_arch" = xx86_64)
AM_CONDITIONAL(HAVE_SPARC_ASM, test "x$asm_arch" = xsparc)
+AM_CONDITIONAL(HAVE_PPC64LE_ASM, test "x$asm_arch" = xppc64le)
AC_SUBST([NINE_MAJOR], 1)
AC_SUBST([NINE_MINOR], 0)