summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 4 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index add3830f233..bca5e9ba5d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1383,18 +1383,10 @@ AC_ARG_ENABLE([libglvnd],
AM_CONDITIONAL(USE_LIBGLVND, test "x$enable_libglvnd" = xyes)
if test "x$enable_libglvnd" = xyes ; then
- dnl XXX: update once we can handle more than libGL/glx.
- dnl Namely: we should error out if neither of the glvnd enabled libraries
- dnl are built
case "x$enable_glx" in
- xno)
- AC_MSG_ERROR([cannot build libglvnd without GLX])
- ;;
xxlib | xgallium-xlib )
AC_MSG_ERROR([cannot build libgvnd when Xlib-GLX or Gallium-Xlib-GLX is enabled])
;;
- xdri)
- ;;
esac
PKG_CHECK_MODULES([GLVND], libglvnd >= 0.2.0)
@@ -1403,6 +1395,10 @@ if test "x$enable_libglvnd" = xyes ; then
DEFINES="${DEFINES} -DUSE_LIBGLVND=1"
DEFAULT_GL_LIB_NAME=GLX_mesa
+
+ if test "x$enable_glx" = xno -a "x$enable_egl" = xno; then
+ AC_MSG_ERROR([cannot build libglvnd without GLX or EGL])
+ fi
fi
AC_ARG_WITH([gl-lib-name],