summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bf288c51bea..1bd02c4a7eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -753,6 +753,12 @@ x*yes*yes*)
;;
esac
+# Building Xlib-GLX requires shared glapi to be disabled.
+if test "x$enable_xlib_glx" = xyes; then
+ AC_MSG_NOTICE([Shared GLAPI should not used with Xlib-GLX, disabling])
+ enable_shared_glapi=no
+fi
+
AM_CONDITIONAL(HAVE_SHARED_GLAPI, test "x$enable_shared_glapi" = xyes)
dnl