summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3c614ea5c4d..c72fe9272b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,7 +73,13 @@ AX_PROG_FLEX([],
AC_CHECK_PROG(INDENT, indent, indent, cat)
if test "x$INDENT" != "xcat"; then
- AC_SUBST(INDENT_FLAGS, '-i4 -nut -br -brs -npcs -ce -TGLubyte -TGLbyte -TBool')
+ # Only GNU indent is supported
+ INDENT_VERSION=`indent --version | grep GNU`
+ if test $? -eq 0; then
+ AC_SUBST(INDENT_FLAGS, '-i4 -nut -br -brs -npcs -ce -TGLubyte -TGLbyte -TBool')
+ else
+ INDENT="cat"
+ fi
fi
AX_CHECK_PYTHON_MAKO_MODULE(0.3.4)